View Full Version : OK, this (probably simple) skimmer issue is driving me nuts!


cr500_af
01-06-2012, 10:46 AM
I've actually had this problem with two different skimmers, one "standard" and one recirc.

With a typical venturi line setup (in between the pump and body, the recirc pump in the case of skimmer #2), why in the world, with everything clean and no obstructions, would the venturi line squirt water instead of drawing in air???

The recirc skimmer is being stored so I'm more concerned about the little one... it's on a 12g tank; a small venturi skimmer that is run by a MJ1200.

Hopefully somebody has the solution even if it makes me feel dumb.

LilRobb
01-06-2012, 11:12 AM
Most likely how the venturi enters the water stream - some have a "nozzle", if that is turned the wrong way it will blow water and not suck air.
Think louvers on a car hood...

cr500_af
01-06-2012, 11:13 AM
Thought of that. One the recir, it is exactly the same as it ran for three years, just came downstairs one day to find water beside the sump... it made the switch while running.

On the other one, I've turned the venturi both ways with no change.

The recirc, like I said, isn't a worry but the little one needs to get functional so the Doc's fishies are happy.

grouper therapy
01-06-2012, 12:07 PM
Has the head pressure changed? Water level in the skimmer. There has to be more water/pressure entering than the pump can handle for it to rise up the venturi supply line. The pump slowing down from wear?

Tony_Caliente
01-06-2012, 12:42 PM
Call me. I can help 770-777-181

cr500_af
01-06-2012, 2:14 PM
Has the head pressure changed? Water level in the skimmer. There has to be more water/pressure entering than the pump can handle for it to rise up the venturi supply line. The pump slowing down from wear?


The water level hasn't changed... I guess wear is possible but the impellers and housings look new on both of them. I can't believe with all of the crap I have around that I don't have another MJ1200 to check with.

The bigger skimmer is on my QT, and since I had to get it going asap I just plugged an air pump to the air line and it is skimming fine.