View Full Version : Vortech MP40 rocks!!!11!1!


JAustin
06-08-2009, 8:48 PM
Just wanted to express my love to my new Vortech MP40! This pump has it all. All the different modes make it a great pump and fun for me to play with. I even put it on short pulse and had a wave rockin for a few min. I'm currentley running it on long pulse at about 75% max power. I love the 10 min time for feeding and the sweet night mode thats 1/2 of my day time set power.

This thing in a 60g cube is perfect! If i ever upgrade it's one thing that won't have to be sold.

What a great pump!

Gwhiz
07-28-2009, 3:51 PM
Not only does the MP40 rock, but the support is great as well. I have an original MP40 who's power supply died. I checked it with a meter to ensure it was the power supply and not the unit, then emailed Ecotech. They asked the age of the unit and I said it was 18 months old (warranty is a year). They sent me a new power supply gratis even though it was out of warranty.

When I got it, I checked to see if it fixed the problem. It did.

I then dismantled the wet side before putting it in bank in the tank, only to find that the magnet was corroded. Another email and a new Gen-2 magnet is on its way...again at no charge.

mapleredta
07-28-2009, 4:00 PM
Not only does the MP40 rock, but the support is great as well. I have an original MP40 who's power supply died. I checked it with a meter to ensure it was the power supply and not the unit, then emailed Ecotech. They asked the age of the unit and I said it was 18 months old (warranty is a year). They sent me a new power supply gratis even though it was out of warranty.

When I got it, I checked to see if it fixed the problem. It did.

I then dismantled the wet side before putting it in bank in the tank, only to find that the magnet was corroded. Another email and a new Gen-2 magnet is on its way...again at no charge.
If that's not great customer service, I don't know what is.

Jgoal55
07-28-2009, 4:47 PM
+1 Dealing Steve at Ecotech is one of the best customer service experiences I have had.

Acroholic
07-28-2009, 5:14 PM
I have two MP40Ws on my chalice tank (about 100 gals.). I had one on the back right glass originally, and it just wasn't enough flow, but I had to keep it down to about 55% because it would stir the sand. I bought another and have it on the back left glass and it works great. Set in Master/slave/lagoon/snyc mode at about 60%. Lotsa flow.

I also have an MP20 on a 60 cube I just set up. Works well.

Great thing about EcoTech is their technical assistance guy. He will stay on the phone and talk you thru stuff. He gives advice, but gives a very sane rationale for all his recommendations.
Dave