View Full Version : Mushroom problem?


ChefBeier
04-12-2008, 1:24 AM
Hello all, new member to the club, I have two hairy mushrooms that are doing well but today I noticed what looked like brown flat worms on them does anyone have any idea how to treat this problem? I have some reef dip but am not sure if that is the answer? Any help would be great! I am still new to the hobby only about 2 years. I have a 37 gal. reef tank and 10 gal reef tank.

calireefer
04-12-2008, 1:45 AM
In my experience they go away on their own. Usually they don't care for much current and besides not looking very nice they don't harm your corals. I would be very cautious about adding any chemicals to kill them as none of them are reef safe. If you do want to nuke them I would pull the shroomz out and dip them.

ChefBeier
04-12-2008, 1:55 AM
Thanks I will watch them for a while and if it doesnt seem to be getting better then I will take them out and dip um!

purpleGORILLA
04-12-2008, 8:55 AM
Can you catch one and put it in so that you can take a picture?

Barbara
04-12-2008, 9:00 AM
Hey, that was your first post! You didn't introduce yourself. Welcome to the club.

It sounds like you have the red flatworms. I have tons of them in my 20G tank, but I have managed not to infect my 90G in the living room so far. I've used a treatment called Flatworm Exit (FE) before, but it didn't work forever. It only seemed to kill them for a few weeks then they came right back. I tried it twice. Now I have the flatworms for the 3rd time and I just leave them alone. I purchased a six line wrasse to try to keep them in check. Hopefully when he's out of quarantine he'll get busy in there!